WordPress automatic upgrade problem

Image representing WordPress as depicted in Cr...
WordPress - now with added 2.8-ness

Full credit for this solution goes to “vtroia” on the WordPress support forum. However, just to ensure the information’s available in more places I’m popping it here.

Symptoms: When trying to use the inbuilt auto-upgrade of WordPress, you simply get a message stating:

Downloading update from http://wordpress.org/wordpress- …

The ending will vary depending on the version you’re trying to update to. Nothing else happens, or it’s just damn slow. There’s no way to tell.

My host is 1and1. I noticed others on the original problem thread had the same one, though I suspect the problem could relate to others as well.

Solution: You need to edit the relevant .htaccess file on your server. This is one of those “for crying out loud, make sure you know what you’re doing” situations, like hacking the registry. Do ensure you have a backup and do ensure you only make the following changes. Make sure you change the correct one, as well.

The problem is that WordPress is either using the wrong version of PHP on the server, or is confused as there is more than one available and it doesn’t know which to pick. Regardless, the solution is to tell it to use PHP5.

To do this, locate and edit the .htaccess file (you may have to download it, edit it and re-upload) and add the following lines:

# Ensure PHP5 being used
# For WordPress auto upgrade
AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php

The first two are only comments, but it’s useful to know what code is doing.

Once saved, retry your upgrade. I found that I now get a pause of around 15-20 seconds when I click on the “Upgrade Now” button, the screen refreshes and the upgrade is done.

Afterwards: Change it back again, or at least add “#” to the bottom two lines. I found that by not doing this, some functionality in WordPress was jiggered. Specifically, the display and edit of the Permalink underneath the post title as you’re entering/editing it. I’m also still missing the “Recommended Link” section from Zemanta but only on Firefox – it’s reappeared when I use Chrome since I restored the .htaccess file. This could be a caching thing, so I’m going to do some more checking and will update this post as and when I find a fix.

Update: The links issue was a Zemanta problem which they’ve swiftly repaired. However, I am now left with a half-functional dashboard page. This isn’t Zemanta – I’ve disabled it to check. I get only the left column of my opening admin screen and none of the pop-up menus work. As soon as I click on one of the non-popped-up buttons, I go to the relevant default screen and everything works again. It’s only the main admin screen. Gah.

Update 2: Seems there are a lot of issues with plug-ins and WordPress 2.8. If you can, check your plug-ins for compatibility before upgrading. However, note that some of the ones I’m having issues with claim to be compatible with this new release.

Update 3: I re-enabled the lines in the .htaccess and it’s resolved most of the issues. And created one tiny one that seems to be ironing itself out. By which I mean sometimes it happens, sometimes it doesn’t. Bizarre.

Just as a disclaimer, it ain’t my fault if you screw your .htaccess by doing this. Be sure you know what you’re doing before to edit it. As long as you only enter the lines shown, as far as I’m aware it will not cause any problems that you can’t sort out by removing the lines again but every installation and setup is different!

Reblog this post [with Zemanta]

11 thoughts on “WordPress automatic upgrade problem”

  1. Thanks for the post. Was having this problem. Dont normally comment on blogs but I just want to let you know I appreciate this post.

  2. THANK YOU for posting this info! I have 3 wordpress blogs on 1and1 and couldn’t figure out the automatic update. I really wanted to upgrade and the .httaccess fix worked perfectly!

  3. Davy, you’re more than welcome. Just to say that true credit goes to “vtroia” on the WordPress forums for the solution. I’m just spreading the word!

  4. Hi Mosher,
    interesting problem this upgrade to 2.8. I did the upgrade without any problem on version 2.5, but when I tried to upgrade a 2.7.1 site (same hoster) it hung, but I did the job manually without a hitch.
    I left my htaccess file unmodified. (i.e. no instructiosn to WP to use PHP)
    It would seem that we have yet to get to the bottom of this. BTW I have no problems with any of the functionality of the dashboard etc.
    Thanks for the info.

    Joe.

  5. Hey Joe 🙂

    My dashboard is now working satisfactorily so I guess that was some kind of “settling in” thing. The last couple of upgrades to the current version have run without a hitch to the point where I no longer use the “Automatic Upgrade” plug-in that I had installed prior to WP building this functionality in. If you’re struggling to get the “proper” auto-upgrade to work then this plug-in’s definitely a viable alternative. It’s not 100% automatic as you need to click your mouse about a dozen times, but it definitely works up to 2.8.

Leave a Reply

Your email address will not be published. Required fields are marked *